Groups Map Plugin for Elgg 1.9

The Groups Map Plugin is now full compatible with Elgg 1.9. You can try it at Elgg 1.9 demo site.